Twitter BootStrap v2 IE6.0兼容扩展

Twitter BootStrap v2这个框架并不支持IE6.0,虽然这是一个好习惯,但在IE6.0依然占据半壁以上江山,并且大老板们都在要求所有浏览器都支持的中国完全不支持IE6是不太现实的一件事。

作为一个不懂设计没有美感的程序员来说,BootStrap这么一个好东西不支持中国大多数的浏览器是一件比较悲催的事,幸好有人专门写了BootStrap的IE6.0的插件。插件项目地址在 github上。

使用说明:

  1. 在head标签中增加<!--[if IE 6]><link href="ie6.min.css" rel="stylesheet><![endif]-->
  2. 在body结束前增加js脚本

   <script type="text/javascript">
            $(function(){if($.browser.msie&&parseInt($.browser.version,10)===6){$('.row div[class^="span"]:last-child').addClass("last-child");$('[class*="span"]').addClass("margin-left-20");$('[class*="span"][class*="offset"]').removeClass('margin-left-20');$(':button[class="btn"], :reset[class="btn"], :submit[class="btn"], input[type="button"]').addClass("button-reset");$(":checkbox").addClass("input-checkbox");$('[class^="icon-"], [class*=" icon-"]').addClass("icon-sprite");$(".pagination li:first-child a").addClass("pagination-first-child")}
                // Tooltip demo
                $('.tooltip-demo.well').tooltip({
                  selector: "a[rel=tooltip]",
                  placement: "top"
                })
                $('.tooltip-test').tooltip()
                $('.popover-test').popover()
                // Popover demo
                $("a[rel=popover]")
                  .popover({
                    placement : "top" 
                   })
                  .click(function(e) {
                    e.preventDefault()
                  })
            });</script>

您可以选择一种方式赞助本站